Can't access jpg files OneDrive

What is the problem you are having with rclone?

Can't access or read files

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.0
- os/version: ubuntu 16.04 (64 bit)
- os/kernel: 4.4.0-131-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.19.4
- go/linking: static
- go/tags: none

Which cloud storage system are you using?


The command you were trying to run (eg rclone copy /tmp remote:tmp)

sudo rclone mount --umask=0 --vfs-cache-mode full OneDrive:/ OneDriveTest/

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":*******************
drive_id = ***************
drive_type = business

A log from the command with the -vv flag

No log file

I create a symbolic link with the path of the photos that is inside on the app that have the php code

ln -s /home/maedco/OneDriveTest/photos/ /var/www/html/app/

but when trying to access the photos through the browser I get restricted access

You don't have permission to access this resource.

I try

sudo chmod +x *.jpg
chmod: cannot access '123.jpg': Permission denied
chmod: cannot access '456.jpg': Permission denied

You are mounting as root so only root can see it.

If that's what you want to do, you need to add --allow-other as fuse mounts are user specific unless you do that.

You can't chmod cloud files as they have no concept of Unix permissions.

thanks a lot, that option works, please close or delete this

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.