Cannot user crypt with local folders without config

What is the problem you are having with rclone?

I cannot use crypt profiles with local folders without config.

I'm trying to run the simplest copy command. If I make a config profile then it works.

This config works, but I'm trying to achieve the same without config:

type = crypt
remote = /full/path/enc
filename_encryption = off
directory_name_encryption = false
password = xxx

What is your rclone version (output from rclone version)

rclone v1.52.2
- os/arch: darwin/amd64
- go version: go1.14.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

macOS 10.15.4

Which cloud storage system are you using? (eg Google Drive)

local folders

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy \
  --config=/dev/null \
  --crypt-filename-encryption=off \
  --crypt-directory-name-encryption=false \
  --crypt-password xxx \
  :crypt:/full/path/enc/ /full/path/dec/

The rclone config contents with secrets removed.

Not using

A log from the command with the -vv flag

2020/07/12 18:05:36 Failed to create file system for ":crypt:/full/path/enc/": failed to parse remote "" to wrap: can't use empty string as a path

hello and welcome to the forum,

i like your profile picture.

    rclone copy /full/path/dec/ :crypt: \
      --config=/dev/null \
      --crypt-remote=/full/path/enc/ \
      --crypt-filename-encryption=off \
      --crypt-directory-name-encryption=false \
      --crypt-password=`rclone obscure thesuperdupersecretpassword` \

and you need to obscure the password

Hi, that part is ok. I've figured out what is the problem, crypt needs a really obscure way of using --crypt-remote when not using config. Somehow with config it isn't needed.

So here is the full command which works:

rclone copy \
  --config=/dev/null \
  --crypt-filename-encryption=off \
  --crypt-directory-name-encryption=false \
  --crypt-password xxx \
  --crypt-remote ./enc \
  :crypt: ./dec/

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.