Cannot login with specific user on MEGA

#1

Hi,

I love using rclone, but recently I stumbled across weird behavior when I set up a new account on MEGA. Unfortunately, I cannot login with that account. I even deleted the account and set it up again just so to make sure I’m not missing something there. A different account works flawlessly.

So here is what I receive when trying to ls the storge.

2018/11/12 00:39:15 DEBUG : rclone: Version "v1.42" starting with parameters ["rclone" "ls" "-vv" "--dump" "bodies" "mega:"]
2018/11/12 00:39:15 DEBUG : Using config file from "/home/USERNAME/.config/rclone/rclone.conf"
2018/11/12 00:39:15 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2018/11/12 00:39:15 DEBUG : HTTP REQUEST (req 0xc4201e3300)
2018/11/12 00:39:15 DEBUG : POST /cs?id=UNDISCLOSED HTTP/1.1
Host: g.api.mega.co.nz
User-Agent: rclone/v1.42
Content-Length: 59
Content-Type: application/json
Accept-Encoding: gzip

[{"a":"us","user":"UNDISCLOSED","uh":"UNDISCLOSED"}]
2018/11/12 00:39:15 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2018/11/12 00:39:16 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2018/11/12 00:39:16 DEBUG : HTTP RESPONSE (req 0xc4201e3300)
2018/11/12 00:39:16 DEBUG : HTTP/1.1 200 OK
Content-Length: 4
Access-Control-Allow-Headers: Content-Type, MEGA-Chrome-Antileak
Access-Control-Allow-Origin: *
Access-Control-Expose-Headers: Original-Content-Length
Access-Control-Max-Age: 86400
Connection: keep-alive
Content-Type: application/json
Original-Content-Length: 4

[-8]
2018/11/12 00:39:16 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2018/11/12 00:39:16 Failed to create file system for "mega:": couldn't login: The upload target URL you are trying to access has expired. Please request a fresh one

Does anyone have an idea about what I can do? There are no shared folders in this account, and the username is just a plain address with nothing special to it. I tried to vary different passwords, none seem to work either.

0 Likes

#2

Try using v1.44 - there was a bug in the logins fixed there.

0 Likes

#3

Hi, I’ve now updated to v1.44.

$ rclone --version
rclone v1.44
- os/arch: linux/amd64
- go version: go1.10.4

Still, I get the same error message.

I’d give you the credentials for you to further investigate this if you want since I would really like to keep this account.

0 Likes

#4

:frowning:

You could dm me with them or email them to me at nick@craig-wood.com

I’m a bit stumped with this problem but cross fingers!

0 Likes

#5

I sent you the credentials per mail.

1 Like

#6

@ncw i have the same error with all new accouns of mega, im using rclone 1.45 Ubuntu 16.04.
Do you think mega is blocking the access to the files through rclone?

0 Likes

#7

I made an issue about this here:

https://github.com/ncw/rclone/issues/2771

The problem is that mega has changed the login procedure for new accounts and the mega library needs updating.

I haven’t had time to look into it yet - any help appreciated!

Unfortunately the “documentation” is their giant C++ SDK.

0 Likes

#8

I’ve posted a fix for this issue here: https://github.com/ncw/rclone/issues/2771

Please give it a go!

0 Likes

#9

Yes, is fixed with the new version

1 Like