Can not install rclone

root@BigNas:~# curl | sudo bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (60) SSL certificate problem: certificate has expired
More details here: curl - SSL CA Certificates

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.
HTTPS-proxy has similar options --proxy-cacert and --proxy-insecure.

please help me

My specs
synology dsm 6.2.3
Linux version

I suspect your CA bundle is out of date on the synology. You can update this I believe but I don't know much about synology.

You can add -k to the curl -k https://... command to download without checking the certificates. Though it is likely to go wrong when the script runs as the install script uses curl so you'd need to edit that and add -k into the curl commands.

Your OS needs to be updated as you are missing the SSL certs patch.

Release Notes for DSM | Synology Inc.

6.2.4 has the fix.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.