Cache-tmp-upload-path is being ignored

What is the problem you are having with rclone?

My problem is that the --cache-tmp-upload-path variable is being ignored and files are located in the vfs cache instead while they are being uploaded. When i go to my specified cache tmp upload path, the folder is empty. The files are instead located in the cache directory. I think this has caused the cache size to increase over my specified maximum size of the cache.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

windows 10, 64 bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

mount gdrive: X: --config C:\Plex\Rclone\rclone.conf --cache-dir=H:\Cache --cache-tmp-upload-path=G:\Uploaden --rc --bwlimit 3M:off --rc-web-gui --rc-user=XXX --rc-pass=XXX --rc-serve --rc-addr :5571 --log-file=C:\Plex\Rclone\downloadlog.txt --size-only --timeout 1h --buffer-size=512M --dir-cache-time=96h --vfs-read-chunk-size=32M --vfs-cache-mode writes --vfs-cache-max-size 50G --vfs-read-chunk-size-limit=2G --vfs-cache-max-age 24h --cache-db-purge --vfs-read-ahead 1G --no-traverse --drive-stop-on-upload-limit

The rclone config contents with secrets removed.

type = drive
client_id = XXX
client_secret = XXXX
scope = drive
token = {"access_token":"XXXX","token_type":"Bearer","refresh_token":"XXX","expiry":"2021-02-04T14:15:26.9460779+01:00"}
root_folder_id = XXXX

A log from the command with the -vv flag

not applicable

That's for the cache backend, which you are not using.

Is the place cache files are stored.

Do you mean that this is also the place where files that are currently uploading are stored?

Yes, that's correct.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.