Cache problems interfering with mount

What is the problem you are having with rclone?

Several days ago, I was uploading a folder to one of my nine mounted remotes. I was uploading by copy and pasting into the mount point folder, not with the command line. I let it upload over night. When I came back the next day, that one remote had come unmounted. I use a script with all of my mount commands, and that script is executed on reboot via crontab. So, I restarted my machine, and the script mounted all of my remotes, except the one in question. I checked my cloud, and saw that many of the files from said folder never uploaded. As a test, I manually mounted the remote with no flags, and came back that night to see that many of the missing files, but not all, had since been uploaded to my cloud. To run a test, I copied some more files, and then uploaded them. They successfully uploaded. I then attempted to manually mount the remote with all of my flags, and the mount failed. I then went to my script, and began commenting out flags one at a time and rebooting the machine with one flag commented out. The script will only successfully mount the remote without the flag --vfs-cache-mode writes. Furthermore, while it will mount the remote, it will not execute any mount commands located later in the script. I have tested this by moving this command to several points in the script, and it is consistent. Once this remote is mounted, the rest of the script fails. I have temporarily resolved this by placing the command at the end of the script.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.2

  • os/version: ubuntu 20.04 (64 bit)
  • os/kernel: 5.4.195-1-pve (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.18.6
  • go/linking: static
  • go/tags: none

Note: I am on a seedbox, and applications are pre-installed. I do not have the option to update to the latest version of rclone.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Since I am using a script to run auto mounts, I will share part of the script here. I use this same exact template for all of my mounts, and it fails only for one specific remote


#Universal Settings

rclone mount Media: /home/MOUNT \
--buffer-size $buffersize \
--attr-timeout $attrtimeout \
--drive-pacer-burst $drivepacerburst \
--drive-pacer-min-sleep $drivepacerminsleep \
--no-checksum \
--poll-interval $pollinterval \
--vfs-cache-mode $vfscachemode \
--dir-cache-time $dircachetime \
--allow-other \
--daemon &

The rclone config contents with secrets removed.

I am unsure what the template means by "secrets removed"

A log from the command with the -vv flag

The output from the -vv command was far too long to paste, so much so that I couldn't even scroll up in the terminal to begining of the output to obtain all of it. However, it was the same output over and over hundreds, if not thousands of times, as so. It is worth noting that all of the items mentioned in the DEBUG lines are my missing files:

2023/02/06 05:27:22 DEBUG : vfs cache RemoveNotInUse (maxAge=3600000000000, emptyOnly=false): item [ITEM NAME] not removed, freed 0 bytes

At the very end, it says
2023/02/06 05:27:22 INFO  : vfs cache: cleaned: objects 1472 (was 1472) in use 0, to upload 0, uploading 0, total size 1.495Gi (was 1.495Gi)

You'd want to add a --log-file /some/location/rclone.log and --log-level DEBUG

and capture the script failing to mount as that's the log you'd want to look at.

I'd imagine the mount is not empty if I had to guess.

Interestingly enough, after running the -vv command, the problem resolved itself after sitting over night. all of my files are available in the cloud now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.