Cache gdrive - no space used in cache folder?

#1

Trying to get a cache setup working on my Windows setup. But after doing the cache later config i cant Seem to see any files being cached on Reading from the mount…

Im guessing thats an issue?

[gdrive]
type = drive
client_id = xyz.apps.googleusercontent.com
client_secret = xyz
scope = drive
token = {“access_token”:"xxxxxxx”

[secure]
type = crypt
remote = gcache:secure
filename_encryption = standard
directory_name_encryption = true
password = xyz
password2 = xyz

[gcache]
type = cache
remote = gdrive:
plex_url = http://localhost:32400
plex_username = xyz@yxz.xxx
plex_password = xyz
chunk_size = 20M
info_age = 1w
chunk_total_size = 10G

Mounting via:

Rclone.exe mount secure: F: —read-only

writing the post made me think and try the following:

C:\rclone>c:\rclone> rclone.exe mount secure: F: --cache-info-age=168h --cache-workers=5 --cache-tmp-upload-path G:\Cache --read-only
The process cannot access the file because it is being used by another process.

C:\rclone>rclone.exe mount secure: F: --read-only
The service rclone has been started.

came to think that I didnt point the cache folder to the folder i wanted to use… but it doesnt seem to work… am i using some wrong commands?

0 Likes

#2

Read metadata is cached in the DB. Try downloading a file from secure: and then check the cache in $HOME/.cache/rclone/

0 Likes

#3

Ah, okay it seems there something inthere after all.

In windows its in %appdata%\Local\rclone\cache-backend

i’ll try and tinker with the settings for my mount command to get the data into the drive i created.

0 Likes

#4

Unsure which cache directory location command to use…

rclone.exe mount secure: F: --cache-tmp-upload-path G:\Cache --read-only

or
rclone.exe mount secure: F: --cache-dir=G:\Cache --read-only

?

0 Likes

#5

What are you expecting to happen?

Cache-tmp stuff is used for uploading files and your mount is read only.

The second is your cache databas.

I think you want the command to store chunks if you are using the cache backend but I’m not sure.

0 Likes

#6

In the %appdata%\Local\rclone\cache-backend i see part of my “secure” folder structure. I was expecting the same to be in the G:\Cache folder when i start with one of the dir commands.

Would preferably want all the content from “%appdata%\Local\rclone\cache-backend” to be in the G:\Cache with one of the commands so all my cache content is placed on the discspace allocated in that drive.

0 Likes

#7

Here are the two settings.

https://rclone.org/cache/#cache-db-path

1 Like