Cache expire and purge question

i have i little problem and a dubt.

I’m using:
rclone v1.41-030-gaa5c5ec5β

  • os/arch: linux/amd64
  • go version: go1.10.1

I’ve mouted google-crypt-cache

As i found on my google mounted drive that are no longer on google i gave cache/expire. At that point on my mounted i see what’s on google, but after some times (i don’t know exactly when) i found the files i had before giving cache/expire.
I think they are restored from cache.
My question is how long is cache supposed to last?
I think i setted 6h, but those file are dated 29/04/18 so shold have been expired.

What shall i do?

Strange… It sounds like your db might be corrupted. Have you tried clearing it?

You mean using rclone DB purge?

Yes using --cache-db-purge

1 Like

I just found out that this problem is still not solved for me.
Even after a --cache-db-purge some time later i found some dirs or files deleted from google but present in my cache.
Any other hint?

Can you provide some logs and screenshots of files and/or directories that have this problem? Also logs from the list commands, configs and mount commands that show the files that shouldn’t exist.

I know it’s a lot to ask but without this data we can’t know where to even start to look.

I must have been drunk.
Now i made a --cache-db-purge and it seems now it is ok.

Let’s see if they will come back.

About this argument.
Is it possible to give --cache-db-purge on a mounted gdrive?
Or can you only do it while mounting?

It only works while the mount is starting since it’s a command line option.

You can kill -SIGHUP the process id if it’s already running if you need to refresh the cache.

1 Like

I still have this problem.
I can solve it by giving cache_db_purge, but isn’t there another way to solve this without purge cache? As i have 50gb of chunks that i don’t like to download again every db purge.