--bwlimit timetable not working as intended

I’m launching rclone with this bandwidth limiter schedule:
--bwlimit "09:00,25 13:00,off 14:00,25 23:59,off Sun-12:00,off Sun-16:00,25"

At 23.59, it disables the limiter: 2018/12/15 23:59:03 NOTICE: Scheduled bandwidth change. Bandwidth limits disabled. That’s good.

But after a few seconds, it returns to 25 KB/s: 2018/12/16 00:00:02 NOTICE: Scheduled bandwidth change. Limit set to 25kBytes/s. I can’t explain why this happens.

What’s is the bug exactly? The speed? You aren’t specifying if it should be mb or kb.

I used this, and it works fine
rclone -v move --bwlimit “18:00,5M 23:59,7M” --checksum --transfers=12 --drive-chunk-size=128M /home/jsd/downloads/manual/Upload GkcryptNoCache:

Maybe my post is not clear, let’s break the bwlimit option in detail:

The issue is that the speed went to unlimited at 23:59, which is correct, but after a few seconds, at midnight, returned to 25 kB/s, and I couldn’t explain why, since I tell rclone to go unlimited after 23:59 an limit to 25 kB/s from 9:00 onwards.

About the unit for the limit, from the docs:

To use a single limit, specify the desired bandwidth in kBytes/s, or use a suffix b|k|M|G.

I agree that they could be referring to the single limit only, and that the timetable might require units, but then in a later example they do this:

An example of a typical timetable to avoid link saturation during daytime working hours could be:
--bwlimit "08:00,512 12:00,10M 13:00,512 18:00,30M 23:00,off"

Which has been the basis of my timetable. As you see, they don’t specify units.

I gave a quick look at the code of rclone, and probably the reason is that I use off instead of 0. I’ll give it a try
EDIT: a deeper look at the code and I discovered they use off in testing BwTimetable. @ncw can you give me a hint?

I can confirm now that substituting off with a zero solves the problem

Yes off means no limiting whereas 0 means limit to 0 bytes/s.