--bwlimit restricts too much on speed

Hi there

I’m on Win10 x64 using --bwlimit 4M with my upload. However the result only got under 3MBytes/s, which is not ideal. Full command can be found on the title bar of the pic.

According to taskmgr, rclone was using on-off mode to control the rate.

40Mbps is my ISP’s upload bandwidth limit, so it’s not about insufficient bandwidth but the way rclone managed to limit the speed.

Maybe switching to other control method will make it more accurate on result.

Which provider are you uploading to?

hi ncw

it’s google drive.

Try increasing --buffer-size - that should help

Tried --buffer-size 1G but no help.
I somehow managed to achieve 3.6MByte/s by setting --bwlimit to 6M.

I think the key is the pulse width of the on-off control.

It is to do with the chunk size. It takes drive some time to process each chunk after upload hence the pause. If you upload multiple files at once rclone will hit the bwlimit exactly.

The only solution is to upload chunks in parallel which I’m not sure drive is capable of.