Bizarre problem - Error 404: File not found

This command works fine:

rclone copy FTP:docs/files tcrypt:

However, this command does not:

rclone copy FTP:docs/files gcrypt:


failed to make directory: googleapi: Error 404: File not found: 0AEH2ik9PVA., notFound

I have no idea why! What am I missing.. ?

when you posted, you should have been asked for some info including debug logs...
need more info about the two different remotes?

Both remotes are identical - that is why I can't figure out why EXACTLY the same command sends to tcrypt: immediately, but attempts to make a directory when sending to gcrypt:

Debug using -vv gives only the above error:
Failed to copy: failed to make directory: googleapi: Error 404: File not found: 0AEH2ik9PVA., notFound

0AEH2ik9PVA. does not exist and has never existed ...

so you have two identical remotes and the exact same command?
can you do a rclone config show for each remote and redact password and ids

Yes - they are identical and have been so since creation more than a year ago.

Both are used daily (Scripts) and I have never seen the above error before.

Full command:

rclone copy FTP:docs/files gcrypt: --fast-list --ignore-case --size-only --checkers 6 --transfers 6 --max-transfer 750G --exclude-from excludes.txt -P -vv

That rclone looks to create a new directory when fed the above command is ... peculiar!

what version of rclone are you running?
what are the backend remotes?
can i ask why you are using two remotes if they are identical?


Backend remotes are Google Drive + Google Shared Drive.

Only I have access to GDrive/gcrypt. Others have access to tcrypt.

not an expert but 404 is often a permission error.

not sure which remote is which?

so if you do not have access to tcrypt, then you could get 404
"The notFound error occurs when the user does not have read access to a file."

Yes, but the peculiar thing is that no permission is being requested - I can upload to either tcrypt: or gcrypt: manually or using rclone browser ... which makes it all the more peculiar that such an error is returned.

Problem solved: the script uses a Service Account .json - which of course can't access gcrypt: ....

That explains why it can't 'read' gcrypt ...

Oops :slight_smile:

glad we solved it :upside_down_face:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.