Best Cache for Plex


#1

Hi, I’m new on rclone and I follow a tutorial to get Plex working with rclone and GDrive, so it works great, but when I play any video, it takes about 15 - 20 secs to start and sometimes it freezes downloading data, the actual config is:
–rc
–log-file ${LOGS}/rclone.log
–log-level INFO
–umask 022
–allow-non-empty
–allow-other
–fuse-flag sync_read
–tpslimit 10
–tpslimit-burst 10
–dir-cache-time=160h
–buffer-size=64M
–attr-timeout=1s
–vfs-read-chunk-size=2M
–vfs-read-chunk-size-limit=2G
–vfs-cache-max-age=5m
–vfs-cache-mode=writes
–cache-dir ${UPLOADS}
So if I put cache-mode full so it will caches in disk the entire video I’m playing, all files in gdrive or only a chunk of video? With this option in “full” I’ll watch without freezes or load the video faster?
Sorry my english I’m Brazilian.


#2

That’s incredibly small. You should move that to 64M or 128M.

Are you using your own rclone API key?
https://rclone.org/drive/#making-your-own-client-id

What version are you using?

You can remove:
–fuse-flag sync_read as that won’t do anything unless you compiled your own version.


#3

So I’ll change the chunk size
Not using own API key, I leave client_id and secret blank, it’s better to create my own?
Using the latest version 1.45
ABout cache to disk, so no need?


#4

Yes, it’s better to use your own client id.

I would not use vfs-cache-mode at all.


#5

Thanks, I’ll try, how can I test if I create and copy and paste the correct client id?


#6

I’m not sure what that means.

I’d run rclone config and re-enter the items in there and not edit any files manually.


#7

You will need to reauthorize when you update the client id… I’m not sure if that is implicitly done when you use rclone config command.