Backup-dir option not working properly

i am doing backup of my unix data on microsoft onedrive via script using below command

rclone sync /unix/datapath remote:backup/weekly -l --backup-dir remote:backup/incremental/$(date +%Y-%m-%d) &

however i have below error message

ERROR : Fatal error received - not attempting retries
Failed to sync: Failed to make fs for --backup-dir “remote:backup/incremental/2019-02-28”: “2019-02-28”: is a not a regular file
ERROR : Fatal error received - not attempting retries

What i notice is that directory backup/incremental/2019-02-28 is created on microsoft one drive cloud. but no changed files are copied in this directory.

could you please let me know what could be issue.

What does a rclone ls of your remote:backup/incremental look like?

rclone ls GD:backup/incremental
104857600 2019-02-28/100M.file

I tried this on onedrive personal and business and it worked fine.

Are you using the latest release?

Hmm, that indicates that rclone is confused about whether backup/incremental/2019-02-28 is a file or not.

What do you get if you do

rclone lsf “remote:backup/incremental/2019-02-28”


rclone lsf "“remote:backup/incremental"

In the latter case do you see 2019-02-28/ (with a trailing slash) in the listing?


Here is the output of commands which you had asked

rclone lsf remote:backup/incremental/2019-02-28


rclone lsf remote:backup/incremental


What version are you running of rclone? I ran through it on Google Drive a few times and your command worked great.

Please find rclone version details below

rclone version

rclone v1.46

  • os/arch: linux/amd64
  • go version: go1.11.5

This looks as it should.

So if you run this command again - what does it do - do you get the same error?

rclone sync /unix/datapath remote:backup/weekly -l --backup-dir remote:backup/incremental/2019-02-28