Automatic Mount for One Drive not Working- token expiry


#1

This post was flagged by the community and is temporarily hidden.


#2

Hmm, is the refresh token set in the config?

It should look like this

token = {"access_token":"XXX","token_type":"Bearer","refresh_token":"XXX","expiry":"2018-11-03T17:45:25.232723892Z"}

use rclone config show onedrive to see what is in the config file.


#3

This post was flagged by the community and is temporarily hidden.


#4

I can’t quite see in the bit you pasted is there a bit which says "refresh_token" in there? It might be a bit difficult to spot as the whole like is 1000s of characters long!

What kind of drive is this? Onedrive for business, or something different?


#5

Yes it’s Onedrive for business.

I can paste the whole bit. I’ve done a search and there is no part which says refresh token.

token = {“access_token”:"removedyourkey
resource_url = https://redhalldudl ey-my.sharepoint.com/

  • I took out your access key as you don’t want to share that

#6

I don’t understand why you didn’t get a refresh token when you made the remote originally!

If you try reauthenticating the remote (with rclone config) does the same thing happen?

Perhaps it is some setting your administrator needs to turn on?

@Cnly do you have any ideas?


#7

Yes, if I use rclone config to edit the settings it prompts me to re-authenticate. I too wonder whether it’s a setting with Onedrive, as I work in a school, and some of the settings are probably locked down so that the students (and staff) don’t mess around with them!


#8


#9

Can you ask the admin? It would be interesting to find out!