Auto config for google drive on windows hung on Got Code


#1

following the guide for setting up google drive…all seems to be going as described, browser pops up after choosing auto-config, selected google account and allowed access to rsync, got

Success!

All done. Please go back to rclone.

…in browser. First time I closed browser but after noticing the Got Code prompt didn’t progress I ctrl+c and started over, this time leaving the browser window open and switching back to terminal window. Unfortunately I have the same sticking point below…

scope> 1
ID of the root folder
Leave blank normally.
Fill in to access “Computers” folders. (see docs).
Enter a string value. Press Enter for the default ("").
root_folder_id>
Service Account Credentials JSON file path
Leave blank normally.
Needed only if you want use SA instead of interactive login.
Enter a string value. Press Enter for the default ("").
service_account_file>
Edit advanced config? (y/n)
y) Yes
n) No
y/n> n
Remote config
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine or Y didn’t work
    y) Yes
    n) No
    y/n> y
    If your browser doesn’t open automatically go to the following link: http://127.
    0.0.1:53682/auth
    Log in and authorize rclone for access
    Waiting for code…
    Got code

I have looked over the forum but was not able to find issues that address this in the first few pages of results.

Any ideas would be greatly appreciated.


#2

If it got this far then rclone got the code from the browser and is trying to exchange it for a token.

I would guess that it is your firewall blocking rclone trying to do that…


#3

Thanks for the response. I’m on Win10 and turned off the firewall to both private and public networks, trying the auto-config after each, and got the same behavior. Is this something I should be able to avoid doing the config manually?


#4

update: I chose ‘n’ at the auto-config question, with firewalls turned back on, did the login and allow on the browser, copied the code back to the terminal and it progressed as expected and the new remote was created successfully. I’ve tested with a lsd and it’s working fine.

Thanks for your help. Let me know if you’d like any other info.


#5

Glad you’ve got it working. I still suspect something to do with firewalling or local networking as this is a process which works for everyone else…

Is there something special about your networking? Ipv6 only maybe? or something else?


#6

I don’t know of anything off standard in my setup thought I’m willing to accept it’s a problem on my side. I’m not using IPv6 at all. Does choosing ‘n’ at the auto-config prompt bypass the need for rclone to turn the code in to a token or does that process work differently going this route?

Thanks again for helping me walk through this. This particular issue has been worked around so I’m good.


#7

n stops rclone having to run a local webserver to receive the response which is the bit that isn’t working for you and the bit I suspect is being firewalled.

Excellent :smiley: