Asynchronous upload (with Cache or VFS)


lately i was following a lot of VFS vs Cache discussions on this board and i got under the impression that if i mount a remote with either VFS or Cache active, upon copying a file to this mount it first gets copied to an intermediate location and then later on transferred to the remote.

Now it seems to that this kind of “async” uploading doesn’t work for me here. All transfers are done synchronously although i tried both of the following mount commands:

/usr/local/bin/rclone mount --vfs-cache-mode writes --allow-non-empty --allow-other --log-file /var/log/rclone.log GDriveCrypt:/ /mnt/gdrive

/usr/local/bin/rclone mount --allow-non-empty --allow-other --log-file /var/log/rclone.log GDriveCachedCrypt:/ /mnt/gdrive

Is that an error in my understanding or am i doing the mount wrong?

Thanks in advance for your help!

With VFS, it copies immediately to the remote.

There is a feature request to make a delay option like cache-tmp-upload ->

With cache-tmp-upload, it depends on the time you have configured in cache-tmp-upload-wait.

So that means if using the Cache Backend it should already work, right?

Yes, you’d have to configure:

   --cache-tmp-upload-path /data/rclone
   --cache-tmp-wait-time 60m

That would copy it locally to the /data/rclone path and not upload it until 60 minutes have passed. It does that via a rclone move command.

Ah thanks mate! Somehow i thought it was using this mechanic by default. Now after adding these options it works!


Happy to assist.