Apache webdav configuration for rclone


#1

How does one enable a GET response in an Apache webdav server to return the properly formatted XML response rclone needs? If I enable directory indexes, obviously the response is HTML and rclone fails?


#2

You can use the http backend to read a standard apache directory listing if you want.

mod_dav looks like the way to go for apache WebDAV serving - I haven’t tried it myself though.


#3

Hi,
I now realize my post was not very clear, sorry. I already have Apache configured with mod_dav however GET requests were returning output that confused rlcone. The relevant settings I have now that seem to work are:

DavLockDB /var/spool/httpd/DavLock
<VirtualHost *:443>
    IndexOptions XHTML SuppressHTMLPreamble Type=text/xml
    <Location /wipro>
        DAV On
        DirectoryIndex disabled
        Options Indexes
        AllowOverride None
    </Location>
</VirtualHost>

#4

No worries.

Great - glad you got it working :slight_smile:

Is that a standard webdav setup for apache or is it a special setup for rclone?

Did you know that rclone also has a webdav server: rclone serve webdav /path/to/files?


#5

Hi,
As far as the documentation suggests, all that is needed is the DavLockDB and DAV On declaration. That enables the functionality however rclone fails to parse GET requests without the index related changes. Although I ommitted everything which is not relevant, I left AllowOverride None for obvious reasons.

I did know about rclone serve webdav however with Apache, I benefit from the rich set of authn/z modules and I happen to associate LDAP users and groups with locations for each user which bind as the potential user. Pretty tough to beat a setup like that as its mostly maintenance free (other than provisioning new users).

Thanks for the help!


#6

OK I see!

rclone serve webdav isn’t industrial strength like an apache setup certainly. Your apache setup sounds quite interesting, I’ll have an experiment apache and webdav if I have time and set up an integration test with it.