Any plans for rclone to work with native Google Doc format

When I use rclone to sync, copy or move Google doc files between Google MyDrive and Google Shared Drives (or different Shared Drives within the same estate), the Google docs will be converted to other non-native formats like 'docx,xlsx,pptx,svg' or 'ods,odt,odp'. It doesn't seem that they can remain in their native format, like with other cloud products (www.cloudhq.net/g_suite). In particular, gsheet files are converted to xlsx. Anyone who uses the QUERY function in Google Sheets will know that it is not compatible with Excel and subsequently the converted file is destroyed. QUERY is a psuedo version of SQL so it is extremely powerful in analysing spreadsheet data. It would be great if rclone could keep Google docs in their native format. Could this be done? Any plans?

I don't believe you can download google docs in native format.

However you can use a server side copy which you'll need to enable with

  --drive-server-side-across-configs      Allow server-side operations (e.g. copy) to work across different drive configs.

This isn't enabled by default as the permissions get tricky. The owner of the destination drive needs to be able to read or move files from the source drive.

If you can get the permissions right then this will move or copy the doc without changing it.

Thank you - that is so helpful and worked perfectly copying a folder in My Drive containing a Google Sheet. I guess as long as the OAuth access allows, it'll work across My Drives and Shared Drives. For ref, I used:

rclone copy MyDrive:"Location1" KPMyDrive:"Location2" --drive-server-side-across-configs

I've subsequently tested this and, within the same domain, it works well moving a Google Sheet:

  1. from My Drive to Shared Drive
  2. from Shared Drive to My Drive
  3. from Shared Drive to Shared Drive

My test file was a Google Sheet equivalent to an 8MB Excel file.

Great - I'm glad that works.

Ideally that setting would be on permanently, but google gives a really whacky 404 error if you don't have the permissions which confuses everyone!