Amazon Cloud Drive Error "Only one auth mechanism allowed"

I have been transferring from ACD to GSuite and recently started getting the following error with Amazon:

error HTTP code 400: "400 Bad Request": response body: "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<Error><Code>InvalidArgument</Code><Message>Only one auth mechanism allowed; only the X-Amz-Algorithm query parameter, Signature query string parameter or the Authorization header should be specified</Message><ArgumentName>Authorization</ArgumentName>

I haven’t run into any trouble listing directories and occasionally a file will transfer but it’s basically just a succession of low level retries with this error.

I’m using the proxy server @ncw put up for ACD and it was working perfect for a while. I tried recreating the acd mount using that method and am still getting the same problem. Any ideas what the issue is or how to fix it?

1 Like

I have the same thing, but with extremely slow transfer speeds.

Try adding --acd-templink-threshold 0 to your rclone command. It seems like ACD has changed the file size threshold for downloading via a tempLink. By setting it to 0, a tempLink is always used. Worked for me at least.

1 Like

Thank you so much fgump it looks like that worked! I think I’m still being throttled by amazon but at least transfers aren’t stopping because of large files.

Thank you @fgump! I’m only a few minutes in but so far no errors and speeds are ~50MB/s. Now to continue copying off acd!

Is there a way of specifying this in the config file?

you can specify as a environment variable before rclone is executed:


Yes, but that’s not the config file…

rclone could be called from a dozen different places (eg cron jobs) across different machines. Being able to specify these flags in the config file is a lot safer than trying to find all those entry points and wrapping the call.

rename rclone to rclone.d and create a batch file named rclone that does set the env variable before running the real rclone behind with the same parameters

There is an issue about that :wink: