Amazon Cloud Drive Connectivitiy issues (1.33, FreeBSD)?

Trying to use rclone to do some backups, configuring for the first time.

Having some trouble (apparently) connecting to ACD. I’ve run rclone configure and performed a remote authorization, but can’t connect. It looks like a DNS issue, but I can resolve the names w/ping. Dump attached below.

root@rclone:~ #	rclone ls acd:/ -v --dump-headers
2016/10/27 15:12:32 rclone: Version "v1.33" starting with parameters ["rclone" "ls" "acd:/" "-v" "--dump-headers"]
2016/10/27 15:12:32 >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2016/10/27 15:12:32 HTTP REQUEST
2016/10/27 15:12:32 GET /drive/v1/account/endpoint HTTP/1.1
User-Agent: rclone/v1.33
Authorization: Bearer Atza|(redacted)
Accept-Encoding: gzip

2016/10/27 15:12:32 >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2016/10/27 15:12:42 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2016/10/27 15:12:42 HTTP RESPONSE
2016/10/27 15:12:42 Error: dial tcp: lookup on dial udp i/o timeout
2016/10/27 15:12:42 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2016/10/27 15:12:42 pacer: Rate limited, sleeping for 287.113937ms (1 consecutive low level retries)
2016/10/27 15:12:42 pacer: low level retry 1/10 (error Get dial tcp: lookup on dial udp i/o timeout)

Is that the nameserver you have configured in /etc/resolv.conf and the nameserver you are expecting to use?

The fact that it worked for configure and did the oauth flow means that the nameservice must have worked then.

The builds I make will be using Go’s built in name resolver so it will look in /etc/resolv.conf find a nameserver and query that. Will that work in your system?

It would be worth trying the latest beta to see if anything has changed there:

If you build from source then you’ll get the libc name resolver which may make a difference on your system.

Well, as of this morning, with no changes, it worked.

I’m guessing it was a transient DNS issue?

I can’t find a shrug emoji, but yes quite possibly!