Add unlisted google cloud regions?

What is the problem you are having with rclone?

I am unable to locate my google cloud storage bucket in rclone.
My cloud storage bucket is in the region northamerica-northeast2 and is of storage class "Standard".
Neither of these options exist in the rclone config tool.

What I've tried

Quite unfamiliar with rclone, and was unable to find much from googling.
I see the connection is valid because it doesnt throw an error, there is just nothing to output.
I have manually edited the rclone config file and updated it from us to northamerica-northeast2

What is your rclone version (output from rclone version)

rclone v1.56.0

  • os/version: debian 10.10 (64 bit)
  • os/kernel: 4.19.0-17-cloud-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.5
  • go/linking: static
  • go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10, 64bit

Which cloud storage system are you using? (eg Google Drive)

Google Cloud and BackBlaze b2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd google:

The rclone config contents with secrets removed.

[backblaze]
type = b2
account = removed
key = removed

[google]
type = google cloud storage
object_acl = publicRead
bucket_acl = publicRead
token = removed
project_number = removed
location = northamerica-northeast2

A log from the command with the -vv flag

2021/08/30 01:27:27 DEBUG : rclone: Version "v1.56.0" starting with parameters ["rclone" "lsd" "google:" "-vv"]
2021/08/30 01:27:27 DEBUG : Creating backend with remote "google:"
2021/08/30 01:27:27 DEBUG : Using config file from "/home/sriamjun21/.config/rclone/rclone.conf"
2021/08/30 01:27:28 DEBUG : 3 go routines active

Not sure how to close this, but I apparently had to target my bucket with Google Cloud even though I'm authenticated as Gcloud owner.

doing rclone lsd google:my-bucket-name fixes it

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.