ACD+Rclone Crypt For Plex [Mac OSX]

hello all, rClone newbie here. Luckily I seem to have figured out the basics and things seem to somewhat be working as intended but I have a few questions to hopeful improve my set-up. Trying to set-up and use my ACD storage for older content that is rarely used in Plex.

I was able to install and set-up rClone, created and ACD remote and then Crypt remote using that ACD remote. Ran a simple copy of a fodler with a text document, it encrypted and uploaded fine. Installed Fuse and then mounted the remote, I’m able to see the decrypted text file in the finder mount and open it.

Next I ran a copy of a folder with 2 video files and then set-up the mount as a test library in Plex, again seemed to all work as intended, but started to run into issues. Files would start playback I would see inbound traffic from ACD but then the file would get about halfway and just stop playback in Plex and there would be no more inbound network traffic. Is there something I should set in the config? I didn’t make any config changes besides what is needed for the install.

Next if/once I get this test working how exactly should my workflow be. It seems Sync and Copy will remove files from ACD if they are removed from the folder locally. My hope is to not have these files locally and only on ACD. I tried copying to the mount by dragging files to it but I get an error and the files won’t write. The only way to get files to ACD are through terminal command of copy.

Copy does not remove any files from local disk.

My suggestion would be to use
rclone move --min-age 6w .

ms - Milliseconds
s - Seconds
m - Minutes
h - Hours
d - Days
w - Weeks
M - Months
y - Years

So you can move older files to ACD and just make sure your point Plex to UNIONFS mount.
/usr/bin/unionfs-fuse -o cow, -o allow_other /path/media-local=RW:/path/acdcrypt=RO /path/media-unionfs

With this your Plex server wont see the difference if files are local or on cloud drive. The above command will mount your media-local folder as read/write and your acdcrypt as read only, so if you copy any file in /media-unionfs it will actually be placed in /media-local folder ( so make sure you are moving files from there to acdcrypt )

As for errors you mention I suggest you temporarily add parameters to your mount so you can check and post possible errors.

rclone mount
acdcrypt: /path/acdcrypt/ &

p.s. Performance wise its better not to use -v --dump-headers --log-file, so remove those once you debug the issues.

I will give these steps a try tonight. I was mis-reading the differences between copy and sync, my plan was to create two dump folders for the content I wanted on ACD and then run the copy every once in awhile. I will look into the mount, I was able to get it to mount fine and could access file through finder as a read only, but I couldn’t just drag and drop files to write, which is what I would like to do instead of running a copy in terminal, is that even possible?

I was able to point Plex at the mount and it did the scan and found everything just seemed to lack performance, my connection is 100/30 so plenty of bandwidth.