Accessing File Share that's mounted on Linux

What is the problem you are having with rclone?

We are using 'rclone mount' to mount S3 storage to a NAS (openmediavault). We are mounting the storage to /srv/dev-by-disk....../files/

When mounted, we cannot access the share drive (although I can run a list command on the /files directory and see the files from S3. When we disable the 'rclone mount' we are able to get into the shared folder. We are attempting to get into the shared folder via File Explorer in Windows 10. SMB.

What is your rclone version (output from rclone version)

Latest stable.

Which cloud storage system are you using? (eg Google Drive)

Wasabi (S3 CLI)

Command used

rclone mount Wasabi:/dmkjr-test/ /srv/dev-disk-by-uuid-4a7edec1-74f2-481d-ae6d-bed0a67fc677/files --file-perms 0777 --dir-perms 0777 --vfs-cache-mode writes


  • have not used openmediavault, but i know this is possible as i do it with synology nas.
    first i create the smb share using the synbox user interface and then rclone mount to that directory.
  • i have done this with ubuntu or was it raspbian, using webmin.
    if you search the forum for webmin, should be able to find that.
  • might try to add --allow-other to the mount command.

Thank you. I will try that this evening. I thought it was possible but was running into a few brick walls. Some of it might just be the syntax of OMV.

You are on to something. With the --allow-other I'm now able to see and open the files. However, it's still not letting me create files/folders or delete. Permissions are set correctly, head down still working on it.

@asdffdsa Okay. I'm stumped again. I have it connecting and showing up as a mounted drive on Windows. However, it's not letting me write. I have the permissions correct, at the NAS level.

When checking permissions in Windows it's showing "pi" (which is the root user still) but shows as Unix User \pi) -- see attached screenshot.

my main user "dmkjr" isn't coming through for some reason. Not sure where that is getting hung up.

good that you are making progress but at this point does not seem like a rclone issue.
if you search the forum, this has been discussed a number of times including the post i mentioned where i used webmin.

for testing, i would create a standard smb share on the pi, get that working with windows.
then try to use rclone mount

@asdffdsa I have the standard share working just fine using SMB.

The permissions issue comes from the mount. I found where the article talks about it here but cannot determine why it's not allowing me to pass anything through (permissions wise).

So we are mounting S3 storage to /srv/dev..... on the RPI (running OpenMediaVault) and then using OpenMediaVault to control the ACL's and normal permissions. Without the drive mounted using rclone, it works fine. As soon as I mount, it removes the privaledges set by OMV and overrides with this.

sorry, do not know.
if i have time later on today, i might take a look.

@asdffdsa Thanks. It appears, and the documentation shows, the three permission sets are being set by the rclone mount. The ACL's from OMV do not work at all (even on the GUI) when the drive is mounted.

i would take a good look at the documenation

-o, --option stringArray Option for libfuse/WinFsp (repeat if required)

The user/group can be customized with FUSE options "UserName" and "GroupName", "

Thanks. I have tried the -o options. Perhaps I do not have the correct syntax. Could you forward me your source? I've ready everything on the rclone mount page.


Actually, I don't need it. However, even passing those through, it doesn't make much difference. Could it be something about mounting the drive to Linux (rpi) and then trying to mount the shared folder to Windows?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.