403 Error but not rate limited

Doing the same thing and recording the log files.

Ok, finally it failed. Line 2359519 is the first 403 Forbidden I can find.


Here’s my log where it fails at line 268354. link

I think i’ve figured out what Plex is doing that google hates… Every file it scans in, it tries to open to do a read from to get the Resolution and other such information (so just more than listing the directory), and this can cause in LARGE Plex libraries an insane number of file.open which google starts rejecting.

I’m not sure how to code around it other than see if once it’s scanning in the whole structure does Plex stop this method.

however that doesn’t explain that why with node-gdrive-fuse that it works perfectly with no bans

disable deep media analyzation in scheduled tasks.

Another interesting “fact”, is BOTH my Google Drive accounts are “blocked” even though they use different client id’s, the only common factor is they come from the same address.

It is some days i don’t have bans anymore.
What i did is using my own id and secret in a different google account than the one of the drive i use.
I don’t know if this helps.

This doesn’t help, you’ll still get banned.

Yes I agree with you after looking at the logs - Plex is opening a lot of files to read a small amount of data from them.

If you can disable that then that will help.

If rclone gains directory caching at some point then that will help too.