2nd rclone instance won't copy from onedrive


#1

I’m getting this error and haven’t been able to find it online.

2018/09/07 21:09:39 ERROR : : error reading source directory: couldn’t list files: unauthenticated: invalidAudienceUri: Invalid audience Uri ‘myonedriveurl’.

I can list everything on both accounts so I know rclone can see the remotes. I just can’t copy or sync

*I changed the actual url to myonedriveurl

these are both business accounts.

I have it working locally in unraid but can’t get it working in a vps where the internet connection is way faster.

encryption is set up with the same passwords on both remotes. I get the same error if I try copying encrypted folders or unencrypted.

any help would be appreciated.


#2

I think this is something to do with the credentials used. Are you using custom client_id?

@Cnly probably has a better idea than me though :wink:


#3

It seems this error comes from the legacy API. What version of rclone are you using @keldona? Could you have a try with the latest beta version that can be found here? Note that you’ll need to re-configure this backend because rclone is migrating to the new API. Thanks!


#4

Version number 1.43 on the vps
And version 1.42 on my local unraid machine.

No I left custom client_id blank

I thought I figured out my problem in trying to reset up the remotes as I was getting a 401 error getting the OneDrive codes on the second and third accounts. I figured out I needed to exit the rclone config in-between setting up each account. After exiting between each account they set up fine ls command shows me all the files. But it still can’t copy as I get the same error.

I’ll try the beta and see how that effects things.

Thanks


#5

The beta fixed whatever issue I was having. Thanks for your help!