1 EB Limit removed?

Lately I have noticed that Rclone mounts GDrive's "Infinite" drive as a maximum of 1 PB, I have tried different methods to get over this limit but it seems to be forced at 1 PB. I own an Enterprise Google Drive account that is connected to the company I work for, we have over 1 PB of data so I virtually cant write anything to the disk unless I figure out a way to get past this.

My proposal:
just add a flag like --max-size-override that allows us to mount Infinite drives at whatever size we want.

It's been like that for a long time. Rclone will always show 1.00 PB free of however much you have stored plus 1 PB. In my case, it's like this:


You can also use

  --vfs-disk-space-total-size SizeSuffix   Specify the total space of disk (default off)
1 Like

I noticed that as well. I was wondering why they removed it in the first place OS limitations?

That command can only set the disk size, as far as I have found. There is no way to directly mount the maximum limit of the OS, it wont change the disk information to the OS, the OS still would see 1PB above the used space not 2 or 3, even if it is specified on mount.

I tried this myself

$ rclone -vv mount /mnt/tmp --vfs-disk-space-total-size 1E drive:

Which gives this

$ df -h /mnt/tmp
Filesystem      Size  Used Avail Use% Mounted on
drive:          1.0E  1.0E   15G 100% /mnt/tmp

Which sets the size to 1EB (and also the used to 15G less than 1EB since this drive only has 15GB free.

What does this do for you?

Which OS are you using?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.