1.49.4 / Plex / Internal Errors on Google Drive

@ncw

Will you remove 1.49.4 from your download section since its buggy? Maybe put 1.49.3 online? :slight_smile:

This link is a proposed v1.49.5 which I'll release once everyone is happy!

https://beta.rclone.org/branch/v1.49.4-003-gb5ea6af6-v1.49-fixes-beta/

So if you could test that it would be much appreciated.

Hi ncw

I dont have the option to test today :frowning: . Im booked the entire weekend.

Well it was just a thought since your download section for the main page will have a faulty rclone . :slight_smile: ?

Hey everybody, glad to see I'm not the only one facing this problem. I have two GDrive mounted, each with it's own clientid on CentOS 7. One of them keeps failing and the other is working perfectly.

As others have explained, the issue only happens after a while. I notice that the command that makes it crash for me is: df -h it will basically hang the session. This is the log file it generated:

2019/10/04 10:15:26 DEBUG : Google drive root 'USB1': Checking for changes on remote
2019/10/04 10:20:56 INFO : Google drive root 'USB1': Change notify listener failure: Get hxxps://www.googleapis.com/drive/v3/changes?alt=json&fields=nextPageToken%2CnewStartPageToken%2Cchanges%28fileId%2Cfile%28name%2Cparents%2CmimeType%29%29&includeItemsFromAllDrives=true&pageSize=1000&pageToken=1847898&prettyPrint=false&supportsAllDrives=true: stream error: stream ID 1921; INTERNAL_ERROR
2019/10/04 10:26:26 INFO : Google drive root 'USB1': Failed to get StartPageToken: Get hxxps://www.googleapis.com/drive/v3/changes/startPageToken?alt=json&prettyPrint=false&supportsAllDrives=true: stream error: stream ID 1923; INTERNAL_ERROR
2019/10/04 10:31:56 INFO : Google drive root 'USB1': Failed to get StartPageToken: Get hxxps://www.googleapis.com/drive/v3/changes/startPageToken?alt=json&prettyPrint=false&supportsAllDrives=true: stream error: stream ID 1925; INTERNAL_ERROR

and this is the mount script I use for both (changed the log to debug to see if anything extra showed up):

rclone mount USB1: /mnt/USB1
--allow-other
--attr-timeout 1000h
--buffer-size 128M
--cache-dir /gcache/USB1/
--checkers=8
--dir-cache-time 96h
--drive-chunk-size=128M
--fast-list
--log-file /root/USB1.txt
--log-level DEBUG
--poll-interval 15s
--rc
--rc-addr 127.0.0.1:5571
--timeout 1h
--transfers=8
--uid 1000
--vfs-read-chunk-size 128M
--vfs-cache-max-age=8h
--vfs-cache-mode=writes

I will try the new build with go1.12 and report back.

1 Like

Nick, this build has been error-free for me for the past two days. Heavy Plex streaming and scanning.

2 Likes

Also having the same issue (Rclone Mount Errors after updates)

rclone v1.49.4
- os/arch: linux/amd64
- go version: go1.13.1

be paranoid my friend,

if the version of rclone you are using is stable and the latest versions of rclone are not stable, then why upgrade at all?

Because It's not stable (1.49.4). That's why im on this thread..

ok.
i have not heard about complaints and bugs with 1.49.3, that is what i use.

is there something specfic in 1.49.4 that forces you to upgrade?

i looked at the change log from 1.49.3 to 1.49.4 and found no reason to upgrade.

I upgraded from an older version (1.48.0). Mainly wanted to get access the the rclone gui, but I still should have stayed on the old version. The beta seems to be working.

@ncw So far, so good. When i was on 1.49.4 and kicked off a sonarr scan, it immediately started freezing. Now on the beta, scans are back to normal speed and the system appears to be working well.

1 Like

That's great! Thanks for testing

I'll probably release it as 1.49.5 tomorrow

I've release v1.49.5 which is the same as v1.49.4 but compiled with go1.12.x

I need to get to the bottom of the go1.13 problems so I'll be needing testers for the latest beta to see if it has the same problems.

rclone

Thank you very much for solution.

I use mount on xpenology working. :raised_hands:

1 Like

Can you say a few words about what was changed (relating to this problem) in the latest beta you link that you want tested?

BTW, I've also had no issue since the last fix-beta that so many people here also reported on.

hey guys,

i am on 1.49.4 too and have had trouble with my google drive too in the last days. I have read something about http2 in this thread which i have no idea about, but i found it in my logs
https://pastebin.com/NYjkq3t7
low level retry keeps increasing (2/10, 3/10) and sleep time too)
The mount is browsable but i cannot do anything with the media. Does not matter if i try to copy a file from the remote or plex wants to read a file, it doesn't work. But the directories are browsable and the debug log will update all of this The log also writes the request of these files, yet it cannot be opened.

API limit has not been reached. There are actually no API requests logged at google after this incident happenes.

hope this helps any of you for troubleshooting.

Nick, this morning I re-mounted with the latest beta (178), and it seemed to work for a while, but I just got home to find the same errors again. The mount was started at 9:48 am, and the first error occurred at 6:36 pm. See here:

2019/10/07 09:48:33 NOTICE: Serving remote control on http://127.0.0.1:5572/
The service rclone has been started.
2019/10/07 18:36:30 INFO : Google drive root 'crypt': Change notify listener failure: stream error: stream ID 1783; INTERNAL_ERROR
2019/10/07 18:42:00 INFO : Google drive root 'crypt': Failed to get StartPageToken: Get https://www.googleapis.com/drive/v3/changes/startPageToken?alt=json&prettyPrint=false&supportsAllDrives=true: stream error: stream ID 1785; INTERNAL_ERROR
2019/10/07 18:47:30 INFO : Google drive root 'crypt': Failed to get StartPageToken: Get https://www.googleapis.com/drive/v3/changes/startPageToken?alt=json&prettyPrint=false&supportsAllDrives=true: stream error: stream ID 1787; INTERNAL_ERROR
2019/10/07 18:53:00 INFO : Google drive root 'crypt': Failed to get StartPageToken: Get https://www.googleapis.com/drive/v3/changes/startPageToken?alt=json&prettyPrint=false&supportsAllDrives=true: stream error: stream ID 1789; INTERNAL_ERROR
2019/10/07 18:53:30 ERROR : IO error: open file failed: Get https://www.googleapis.com/drive/v3/files/0BytoIhEE1nQfRWN4aXZxb1RXYnM?alt=media: stream error: stream ID 1781; INTERNAL_ERROR

No scanning involved. Just a few streams throughout the day. The mount did not crash, btw.

Can you try with the latest beta but with HTTP disabled? So set this environment variable before you run rclone

export GODEBUG=http2client=0

All the error reports I've seen have HTTP2 stuff in them so that may help narrow the problem down if it works.

All the errors in this thread look like this which are internal errors from the http library

Failed to get StartPageToken: Get https://www.googleapis.com/drive/v3/changes/startPageToken?alt=json&prettyPrint=false&supportsAllDrives=true: stream error: stream ID 1785; INTERNAL_ERROR

Digging through lots of go issues, I think this may be caused by a timeout, which kind of makes sense as the changes api is long living.

I don't know whether these errors are normal, but rclone isn't retrying them...

This might be something to do with the context being cancelled also...

Will think some more!

OK here is a beta compiled with go1.13 which will use http2 and exhibit the same problem.

However I've made it retry the http stream error, so hopefully it will fix the problem

Any testing much appreciated :slight_smile:

https://beta.rclone.org/branch/v1.49.5-180-gea304f41-fix-http2-retry-beta/ (uploaded in 15-30 mins)

Fixing this is a release blocker for v1.50 which I want to release compiled with go1.13

Is this something I can do in Windows? I will test your latest build today and let you know what happens. Thanks!